summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortechge2018-05-02 07:52:09 +0200
committertechge2018-05-02 07:52:09 +0200
commit747fd976ddf46c874e1d27ec7b26cf004e884d54 (patch)
tree81f2aa85c7f2513d48a77b57c26ce4f341f472c5 /PKGBUILD
parent7b5015cf018c8cefb153fd8f925e7c159f78d932 (diff)
downloadaur-747fd976ddf46c874e1d27ec7b26cf004e884d54.tar.gz
Python modules disabled and new commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f22aa82f569b..8d43fdad0a43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
pkgname=kismet-git
-pkgver=019a7ef
+pkgver=c4d58f0
pkgrel=1
pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2016_07_R1-1"
arch=('x86_64')
url="https://www.kismetwireless.net/"
license=('GPL')
-depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm' 'protobuf' 'protobuf-c')
+depends=('libelf' 'libmicrohttpd' 'libnm' 'libpcap' 'pkg-config' 'protobuf' 'protobuf-c')
optdepends=('hackrf: use with HackRF compatible software defined radio (SDR)')
conflicts=('kismet')
backup=('etc/kismet/kismet.conf' 'etc/kismet/kismet_alerts.conf' 'etc/kismet/kismet_httpd.conf' 'etc/kismet/kismet_logging.conf' 'etc/kismet/kismet_memory.conf' 'etc/kismet/kismet_storage.conf')
install=kismet.install
source=("${pkgname}-${pkgver}.zip::https://github.com/kismetwireless/kismet/archive/${pkgver}.zip"
"${pkgname}-sysusers.conf")
-sha256sums=('c41b88ffc374e71353197ee7c07a673f2a86f8a89edb1fc59b9f43c68013cbaf'
+sha256sums=('351179b24e4772650b59addddb919e46fe2554344fddf60381160a8c84f3c037'
'8b5b25bb6d9c611589ce0200da3cfeed2194bfa45aeed88e10c980c668383806')
build() {
cd kismet-${pkgver}*
./configure --prefix=/usr \
- --sysconfdir=/etc/kismet
+ --sysconfdir=/etc/kismet \
+ --disable-python-tools
make
}