summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlberto Sánchez Molero2022-11-04 23:54:11 +0200
committerAlberto Sánchez Molero2022-11-04 23:54:11 +0200
commit665bcf44d4cec99e02e9b5f958369eb725687243 (patch)
treee4009ae43e534bf856fabca3845c03daa66d22fb /PKGBUILD
parent96f21f6999849a4bcbfd25f529336b6ca42d91da (diff)
downloadaur-665bcf44d4cec99e02e9b5f958369eb725687243.tar.gz
update to 3.2.1, added patch to avoid having PDF attachments appear corrupted
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 680fee67ce96..81562ab9aba4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alberto Sánchez Molero <alsamolero@gmail.com>
pkgname=kitsas
_reponame=kitupiikki
-pkgver=2.1.1
+pkgver=3.2.1
_repover="${pkgver//_/-}"
pkgrel=1
epoch=
@@ -21,11 +21,20 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/artoh/$_reponame/archive/v$_repover.tar.gz")
+source=(
+ "https://github.com/artoh/$_reponame/archive/v$_repover.tar.gz"
+ "0001_dont_process_pdf_as_image.patch"
+)
noextract=()
-sha256sums=(36b6d8611c412ff930169aacb87c8263f61c10dbd163ebaeddb62f05652c4a60)
+sha256sums=('79574ceefe457eae5e9174577979871618c7cb32bbdd35cce234ff6219017432'
+ 'f0cea2431af21d7640c869856ce16609d340fe45c2c997e72123cea78febc454')
validpgpkeys=()
+prepare() {
+ cd "$_reponame-$_repover"
+ patch -N -p1 -i "${srcdir}/0001_dont_process_pdf_as_image.patch"
+}
+
build() {
cd "$_reponame-$_repover/$pkgname"
qmake $pkgname.pro -spec linux-g++ "CONFIG+=release"