diff options
author | hashworks | 2020-06-08 14:02:55 +0200 |
---|---|---|
committer | hashworks | 2020-06-08 14:02:55 +0200 |
commit | 594684b7cf15077b231375d0ec8e64c8787d537a (patch) | |
tree | e17948462b4fb0b69cde4f135e213758603faf37 /PKGBUILD | |
parent | d3ff81db189674bcb3cfad4a04a2cbc3f1f55b02 (diff) | |
download | aur-594684b7cf15077b231375d0ec8e64c8787d537a.tar.gz |
Add license file to package
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 18 |
1 files changed, 10 insertions, 8 deletions
@@ -3,32 +3,34 @@ # Contributor: nic96 pkgname=kiwix-desktop-git +_pkgname="${pkgname%-git}" pkgver=2.0.1.r13.g2c98856 -pkgrel=1 +pkgrel=2 pkgdesc="Offline reader for Web content, especially intended to make Wikipedia available offline." url="https://github.com/kiwix/kiwix-desktop" arch=("i686" "x86_64") license=("GPL3") depends=("qt5-base" "qt5-webengine" "qt5-svg" "qt5-imageformats" "kiwix-lib") makedepends=("qt5-tools" "git") -conflicts=("${pkgname%-git}") -provides=("${pkgname%-git}") -source=("${pkgname%-git}::git+${url}") +conflicts=("${_pkgname}") +provides=("${_pkgname}") +source=("${_pkgname}::git+${url}") sha256sums=("SKIP") pkgver() { - cd "$srcdir/${pkgname%-git}" + cd "$srcdir/${_pkgname}" git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' } build() { - cd "$srcdir/${pkgname%-git}" - qmake PREFIX="$pkdir/usr" + cd "$srcdir/${_pkgname}" + qmake PREFIX="${pkgdir}/usr" make } package() { - cd "$srcdir/${pkgname%-git}" + cd "$srcdir/${_pkgname}" + install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" make INSTALL_ROOT="$pkgdir/" install } |