summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:46:55 +0000
committerJoão Figueiredo2023-02-13 00:46:55 +0000
commit689dad6adad2e491de0d17a9cfb88313152ea42e (patch)
tree5b6f09546c1eb82cef49388379af5a05eccc926e /PKGBUILD
parent79f37a27256e05815ebd3df30324a28db70d2f1e (diff)
downloadaur-689dad6adad2e491de0d17a9cfb88313152ea42e.tar.gz
Migrate to Qt6 (this time for real!)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e40fa84eba6b..246d0b283129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,18 @@ pkgdesc='Widgets for tracking KJob instances'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(kcoreaddons-git kwidgetsaddons-git qt5-x11extras)
-makedepends=(git extra-cmake-modules-git qt5-tools clang python-pyqt5 doxygen sip4)
+depends=(kcoreaddons-git kwidgetsaddons-git qt6-x11extras)
+makedepends=(git extra-cmake-modules-git qt6-tools clang python-pyqt6 doxygen sip4)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-optdepends=('python-pyqt5: for the Python bindings')
-groups=(kf5-git)
+optdepends=('python-pyqt6: for the Python bindings')
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}