summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen2015-11-05 09:44:56 +0800
committerAllen2015-11-05 09:44:56 +0800
commitd34ba95d513d25f92895f1d89601db87112c1cda (patch)
treed1bc35fe491a134ff7599036f67afd6195bc382c /PKGBUILD
downloadaur-d34ba95d513d25f92895f1d89601db87112c1cda.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f15493dd800f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Allen Choong <allen.choong at gmail dot com>
+pkgname=klatexformula
+pkgver=3.3.0beta
+pkgrel=1
+pkgdesc="Provides GUI for generating images from LaTeX equations"
+url='http://klatexformula.sourceforge.net'
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('automoc4' 'kdelibs' 'kdebase-runtime')
+source=("http://sourceforge.net/projects/klatexformula/files/klatexformula/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('0458282acadeb52e50e4d4148f41c592')
+install="${pkgname}.install"
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ sed -i "s|(uninstall|(uninstall2|" cmake/klfinstallpaths.cmake
+ mkdir build && cd build
+ cmake ..
+ make DESTDIR="${pkgdir}/" install
+}