summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean-Luc Tambasco2018-10-03 11:40:05 +1000
committerJean-Luc Tambasco2018-10-03 11:40:05 +1000
commit0665ae6165064c377c1f975af8758cd585939f32 (patch)
treede558e2137eb37464f1db59aaf9ea6ff70555cb8 /PKGBUILD
parent610a2554fb6ea1fd4315400faf213944c3d0d7bf (diff)
downloadaur-0665ae6165064c377c1f975af8758cd585939f32.tar.gz
Multithreaded the build process. Enforced klayout be compiled with Qt5.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23dbf9c317ba..739a679d7bac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,9 +29,14 @@ pkgver() {
build() {
cd "$srcdir/klayout"
+ # Get thread count to multithread build process.
+ threads="$(grep -c ^processor /proc/cpuinfo)"
+
build_opt="-qmake /usr/bin/qmake
-ruby /usr/bin/ruby-2.3
- -python /usr/bin/python3"
+ -python /usr/bin/python3
+ -j${threads}
+ -qt5"
# apply patch
cd ./src/db/db