summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean-Luc Tambasco2019-05-23 23:41:37 +1000
committerJean-Luc Tambasco2019-05-23 23:41:37 +1000
commit2b87656261094dfa16910065333d1ac00bd75e5c (patch)
treee0859e6ebb751978c221169739d825bed4133a6d /PKGBUILD
parenta4793b5577578dd7db3215b0f15f8f75027095fa (diff)
downloadaur-2b87656261094dfa16910065333d1ac00bd75e5c.tar.gz
Updated build to work with new version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59634b1e0dfc..b1736f2654ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=klayout
pkgname=klayout-git
-pkgver=v0.25.4.r47.g9dd603bb
+pkgver=v0.25.8
pkgrel=1
pkgdesc="High Performance Layout Viewer And Editor. Support of GDS and OASIS files."
arch=('i686' 'x86_64')
@@ -21,14 +21,14 @@ md5sums=(SKIP
pkgver() {
cd "$_pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git tag | tail -1
}
build() {
cd "$srcdir/klayout"
# Get thread count to multithread build process.
- threads="$(grep -c ^processor /proc/cpuinfo)"
+ threads="$(($(grep -c ^processor /proc/cpuinfo) + 1))"
build_opt="-qmake /usr/bin/qmake
-ruby /usr/bin/ruby