summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Mangold2022-12-02 11:00:24 +0100
committerOliver Mangold2022-12-02 11:22:48 +0100
commit7495b8cfdc0dc2056bd0523b4016c391ed5c3d55 (patch)
treed19d8329be64f5408949ed6498c1418070931cc6 /PKGBUILD
parent5133b37d23d45cae8214639e914e906ffc49729f (diff)
downloadaur-7495b8cfdc0dc2056bd0523b4016c391ed5c3d55.tar.gz
complete rewrite:
- do not use systemd but, but pacman hooks - do not use custom modprobe, but symlink from /usr/lib/modules to /var/cache/kmods
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3101f834f76f..e36e64660b15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,18 @@
# Maintainer: Oliver Mangold <o.mangold@gmail.com>
pkgname=kmodcache
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Scripts to make a copy of installed kernel modules, which will be used for on-demand loading from then point on, thus make reboots unnecessary after kernel updates."
arch=('any')
license=('GPL3')
depends=()
makedepends=()
-source=('kmodcache.conf' 'modprobe' 'make-kmod-cache' 'kmodcache.service')
+source=(pre-upgrade post-upgrade kmodcache-pre.hook kmodcache-post.hook)
sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
package() {
- #cd "${pkgname}"
- install -m 755 -d "$pkgdir"/usr/lib/modules "$pkgdir"/usr/lib/sysctl.d "$pkgdir"/usr/lib/systemd/system "$pkgdir"/usr/bin "$pkgdir"/usr/local/bin
- install -m 755 make-kmod-cache "$pkgdir"/usr/bin
- install -m 755 modprobe "$pkgdir"/usr/local/bin
- install -m 644 kmodcache.conf "$pkgdir"/usr/lib/sysctl.d
- install -m 644 kmodcache.service "$pkgdir"/usr/lib/systemd/system
- ln -s /var/cache/kmods "$pkgdir"/usr/lib/modules/cached
+ install -m 755 -d "$pkgdir"/usr/lib/kmodcache "$pkgdir"/usr/share/libalpm/hooks
+ install -m 755 {pre,post}-upgrade "$pkgdir"/usr/lib/kmodcache
+ install -m 644 *.hook "$pkgdir"/usr/share/libalpm/hooks
}