summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Mangold2018-02-27 12:01:00 +0100
committerOliver Mangold2018-02-27 12:01:00 +0100
commitef68af96fd7ea01c71481aac2508caa7da488f59 (patch)
tree344f469c4ae3bc5af25067333d72cea30b593d54 /PKGBUILD
downloadaur-ef68af96fd7ea01c71481aac2508caa7da488f59.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65eb20bc6e9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Oliver Mangold <o.mangold@gmail.com>
+
+pkgname=kmodcache
+pkgver=1.0
+pkgrel=1
+pkgdesc="Scripts to make a copy of installed kernel modules, which will be used for on-demand loading from then point on, thus make reboots unnecessary after kernel updates."
+arch=('any')
+license=('GPL3')
+depends=()
+makedepends=()
+source=('kmodcache.conf' 'modprobe' 'make-kmod-cache' 'kmodcache.service')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+package() {
+ #cd "${pkgname}"
+ install -m 755 -d "$pkgdir"/usr/lib/modules "$pkgdir"/etc/sysctl.d "$pkgdir"/usr/lib/systemd/system "$pkgdir"/usr/bin "$pkgdir"/usr/local/bin
+ install -m 755 make-kmod-cache "$pkgdir"/usr/bin
+ install -m 755 modprobe "$pkgdir"/usr/local/bin
+ install -m 644 kmodcache.conf "$pkgdir"/etc/sysctl.d
+ install -m 644 kmodcache.service "$pkgdir"/usr/lib/systemd/system
+ ln -s /var/cache/kmods "$pkgdir"/usr/lib/modules/cached
+}