summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Mangold2020-04-22 13:34:18 +0200
committerOliver Mangold2020-04-22 14:05:36 +0200
commit09598a5201170ccef645563013041a1096a69e61 (patch)
tree78f17474c73cf761d19a6d5f5fd00be5b59cfba8 /PKGBUILD
parent69c9f01871050e604d834db1972a2244f5eb2f17 (diff)
downloadaur-09598a5201170ccef645563013041a1096a69e61.tar.gz
- major rework
- update to version 6.13.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 35 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d7e5ec09250..96f944f26760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,44 @@
-# Maintainer: Alexander Susha <isushik94@gmail.com>
pkgname=kms-elements
-pkgver=6.7.1
+pkgver=6.13.0
pkgrel=1
-pkgdesc='Kurento elements module'
-arch=('any')
-url='http://www.kurento.org/'
-license=('LGPL v2.1')
-depends=('boost-libs' 'libnice' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core>=6.7.0')
-makedepends=('cmake' 'libnice' 'boost-libs' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core>=6.7.0' 'valgrind')
-provides=(${pkgname})
-conflicts=(${pkgname})
-source=("https://github.com/Kurento/${pkgname}/archive/${pkgver}.tar.gz"
- 'kmselements.c.patch'
- 'kmsrecorderendpoint.c.patch'
- 'kmsrtpendpoint.c.patch'
- 'kmswebrtcendpoint.c.patch'
- 'kmswebrtc.c.patch')
-sha256sums=('880f37343aed8165aa08e8b8f05a99455cfd1f37e59bebc224bf77737ac5d147'
- 'a158f1da9ae727523da02b53b2014fdc5de0a2239b0b187771f3eec6d85defee'
- 'e705e135da4dea3197967ab067c2dde898197b054548baa3337930ca727328c0'
- '02e6075f1f29a46a2df13655d3186ac23535de24489047126ed7c25d77afbcf3'
- 'a923b2ebd0cb8ee332c7e5ce7d76d8fa2558c67ddfb1cdeaadb8774853f3cb66'
- 'aa12fece95385cfc6c7522b2afe6101220fa3215b9d03fcb30de7eb1cd06032a')
+pkgdesc="Kurento server media elements"
+arch=(any)
+url="https://github.com/Kurento/kms-elements"
+license=(apache)
+depends=(boost kms-core libnice gstreamer gst-plugins-base gst-plugins-bad)
+makedepends=(kms-cmake-utils kurento-module-creator)
+source=(
+ "git://github.com/Kurento/$pkgname.git#tag=$pkgver"
+ cmake-boost.patch
+ kmselements.c.patch
+ kmsrecorderendpoint.c.patch
+ kmsrtpendpoint.c.patch
+ kmswebrtcendpoint.c.patch
+)
+sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP)
-prepare(){
- cd ${srcdir}/${pkgname}-${pkgver}
-
- patch -Nup0 < ../kmselements.c.patch
- patch -Nup0 < ../kmsrecorderendpoint.c.patch
- patch -Nup0 < ../kmsrtpendpoint.c.patch
- patch -Nup0 < ../kmswebrtcendpoint.c.patch
- patch -Nup0 < ../kmswebrtc.c.patch
-
- for FILE in $(find . -type f)
- do
- sed -i -E "s/gstreamer\-((\w|\d)+\-)?1\.5/gstreamer-\11.0/g" $FILE
- done
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p0 <"$srcdir/cmake-boost.patch"
+ patch -p1 <"$srcdir/kmselements.c.patch"
+ patch -p1 <"$srcdir/kmsrecorderendpoint.c.patch"
+ patch -p1 <"$srcdir/kmsrtpendpoint.c.patch"
+ patch -p1 <"$srcdir/kmswebrtcendpoint.c.patch"
+ sed -ri -e 's#gstreamer((-[-a-z]+)?)-1\.5#gstreamer\1-1.0#g' {,*/,*/*/,*/*/*/,*/*/*/*/}CMakeLists.txt
}
+
build() {
- mkdir -p "build"
- cd "build"
- cmake ${srcdir}/${pkgname}-${pkgver}/. -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_C_FLAGS="-Wno-incompatible-pointer-types" -DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations"
+ local builddir=$srcdir/$pkgname/build
+ rm -rf "$builddir"
+ mkdir "$builddir"
+ cd "$builddir"
+ cmake -DCMAKE_MODULE_PATH=/usr/share/cmake/Modules -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_BUILD_TYPE=Release ..
+ make
}
+
package() {
- make -C build DESTDIR="${pkgdir}" install
- mv ${pkgdir}/usr/etc ${pkgdir}/
+ local builddir=$srcdir/$pkgname/build
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
}