summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2020-05-29 10:54:11 +0200
committerAntoine Viallon2020-05-29 10:54:11 +0200
commite23121b25e22a0df366f03270156c97af258535d (patch)
treed419d6d918777663370a90bbb76eb9ef34ddbb08 /PKGBUILD
downloadaur-e23121b25e22a0df366f03270156c97af258535d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9296cec8f1be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Antoine Viallon <antoine.viallon@gmail.com>
+
+pkgname=knightos-kcc-git
+_pkgname=kcc
+pkgver=4.0.0.r5.gefd439995
+pkgrel=1
+license=('GPL')
+pkgdesc='A C compiler for z80 systems'
+depends=("scas" "boost")
+makedepends=("cmake" "asciidoc")
+arch=("x86_64")
+url='https://github.com/KnightOS/kcc'
+source=("${_pkgname}::git+https://github.com/KnightOS/kcc")
+sha256sums=('SKIP')
+provides=("knightos-kcc")
+conflicts=("knightos-kcc")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir/" make install
+}