summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNorbert Pfeiler2019-05-02 03:34:45 +0200
committerNorbert Pfeiler2019-05-02 03:34:45 +0200
commita45ad0aae5cc5464502cccd4a81f9183c9fbea36 (patch)
treeab3ccf7eed3dab3a4636622128e185d656a3688a /PKGBUILD
parentb77b3dd579d0a9623352308212cc22c2de8d3fea (diff)
downloadaur-a45ad0aae5cc5464502cccd4a81f9183c9fbea36.tar.gz
backport GCC8 fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46e536fa6404..e404f65453db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
pkgname=knossos
pkgver=5.1
-pkgrel=1
-arch=('x86_64')
+pkgrel=2
+arch=("x86_64")
pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
-url="https://www.knossostool.org/"
+url="https://knossos.app"
license=("GPL2")
depends=("glu"
"qt5-base"
- "qt5-python27-git" # qt5-python27
- "qt5-tools" # Qt5Help
- "quazip-qt5"
- "snappy"
+ "qt5-python27-git" # qt5-python27
+ "qt5-tools" # Qt5Help
+ "quazip-qt5"
+ "snappy"
)
makedepends=("boost"
"cmake"
@@ -25,9 +25,16 @@ optdepends=("qt5-imageformats" # Jp2
)
source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
"knossos.desktop"
+ "GCC8-combat-K5.patch"
)
md5sums=('fd97340a07b58b3f1b1543405d893c35'
- '1a2b3733cf5fcb3e1845ce771abb58e9')
+ '1a2b3733cf5fcb3e1845ce771abb58e9'
+ '9e6daa1198b3f819379995d37178e3d1')
+
+prepare() {
+ cd "knossos-$pkgver"
+ patch -p1 -i ../GCC8-combat-K5.patch
+}
build() {
mkdir -p "build-$CHOST-$pkgname-$pkgver"