summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNorbert Pfeiler2023-01-24 02:14:48 +0100
committerNorbert Pfeiler2023-01-24 02:14:48 +0100
commit702243fa29c01d81174043889d21aa08a41f77a6 (patch)
treea17c804a6b688e32bb87dcd559217e06fdbcab3e /PKGBUILD
parent08fe607402c2db9506ad58bbdec8e5cb7bf7bec2 (diff)
downloadaur-knossos4.tar.gz
fix some includes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a2151f23bf9..9e0b6d1cc6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=knossos4
pkgver=4.1.2
-pkgrel=16
+pkgrel=17
arch=(x86_64)
pkgdesc='A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.'
url='https://knossos.app'
@@ -51,6 +51,8 @@ prepare() {
patch -p1 -i ../f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
sed 's/snprintf(remoteURL, CSTRING_SIZE, url.toStdString().c_str());/snprintf(remoteURL, CSTRING_SIZE, "%s", url.toStdString().c_str());/' -i network.cpp
sed 's/NOT CMAKE_CXX_COMPILER_ID MATCHES "Clang"/FALSE/' -i CMakeLists.txt # breaks using/linking some std functions (min, max, …)
+ sed '/#include <QThread>/a #include <deque>' -i remote.h
+ sed '/#include <QWaitCondition>/a #include <array>' -i stateInfo.h
pythonqt="Qt5Python$(pacman -Q python | cut -d' ' -f2 | cut -d. -f1-2 --output-delimiter '')"
echo using $pythonqt