summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2023-10-03 12:14:58 -0400
committerPatrick Northon2023-10-03 12:14:58 -0400
commit659c1256eda8e963458a053abaf3896f65722cdc (patch)
tree6537de79e9ff959c02087df7675197f206a01598 /PKGBUILD
downloadaur-659c1256eda8e963458a053abaf3896f65722cdc.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f465bdcf532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=kodi-addon-jellyfin
+pkgver=0.7.11
+pkgrel=1
+pkgdesc='Synchronize your media on your Jellyfin server to the native Kodi database.'
+url='https://github.com/jellyfin/jellyfin-kodi'
+license=('GPL3')
+depends=('kodi' 'python-kodi_six' 'python-dateutil' 'python-requests' 'python-six' 'python-websocket-client')
+groups=('kodi-addons')
+makedepends=('unzip' 'python-yaml')
+arch=('any')
+sha256sums=('6dac1929fe42aa37cb6a455e203f97a7c0752d5a09865743014a932342958dd3')
+source=("${pkgname}-${pkgver}::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+
+_srcdir="jellyfin-kodi-${pkgver}"
+
+build() {
+ cd "${_srcdir}"
+ ./build.py --version 'py3'
+}
+
+package() {
+ cd "${_srcdir}"
+ install -dm755 "${pkgdir}/usr/share/kodi/addons"
+ unzip 'plugin.video.jellyfin+py3.zip' -d "${pkgdir}/usr/share/kodi/addons"
+}