summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordhead6662015-11-23 10:51:04 +0200
committerdhead6662015-11-23 10:51:04 +0200
commit5ff56060fb16fbcfe926c4714ef868a149a20596 (patch)
tree2a53045c9b3ac53dccd81d73a6f22c9636234d25 /PKGBUILD
parent225d0a0bd22a67a4f0e4e0fee89c95f09f329d96 (diff)
downloadaur-5ff56060fb16fbcfe926c4714ef868a149a20596.tar.gz
bump to kodi 16.0b2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 2 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 196be347ab35..41663d5423e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,17 +16,14 @@
# Original credits go to Edgar Hucek <gimli at dark-green dot com>
# for his xbmc-vdpau-vdr PKGBUILD at https://archvdr.svn.sourceforge.net/svnroot/archvdr/trunk/archvdr/xbmc-vdpau-vdr/PKGBUILD
#
-# The PKGBUILD includes easy ways to:
-# 1) build from specific commit (without having to clone the whole repository)
-# 2) test new features by adding a list of Github's PR numbers
+# To build a specific commit without having to clone the whole repository
+# set "pkgver" as commit sha and "_gitver" as "$pkgver".
pkgbase=kodi-devel
pkgname=('kodi-devel' 'kodi-devel-eventclients')
_gitname=xbmc
-# when building specific commit: 1) pkgver=commit_sha 2) _gitver=$pkgver
pkgver=16.0b1
-#_gitver=$pkgver
_gitver=$pkgver-Jarvis
_pkgsrcname=$_gitname-$_gitver
@@ -56,16 +53,6 @@ prepare() {
cd "${srcdir}/$_pkgsrcname"
- # test new features by adding Github PR numbers, e.g. prlist=('6615')
- prlist=('')
- if [[ $prlist != '' ]]; then
- msg "Adding new features to test..."
- for pr in $prlist; do
- curl -o $srcdir/$pr.patch https://github.com/xbmc/xbmc/pull/$pr.patch
- patch -p1 -i $srcdir/$pr.patch
- done
- fi
-
find -type f -name *.py -exec sed 's|^#!.*python$|#!/usr/bin/python2|' -i "{}" +
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
sed 's/python/python2/' -i tools/Linux/kodi.sh.in