summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2019-05-13 19:48:25 -0400
committergraysky2019-05-13 19:48:25 -0400
commita9807941c7d370165c76a20188006b7c9f344a92 (patch)
tree2c9cf75d0c4d2e47f97d7b0b4fd9256edae9668d /PKGBUILD
parent9744c61ab59419898f4805a189e714979b3f0fed (diff)
downloadaur-a9807941c7d370165c76a20188006b7c9f344a92.tar.gz
Update to 18.3rc1pre15-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd97336893f5..2042c460a526 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ pkgname=(
)
pkgver=18.3rc1pre15
_major=18.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
@@ -132,6 +132,11 @@ sha256sums=('07b8cffc396473523a51354dc95dfffb54a6a456b82cda7ad67dc2c052d99f64'
'04832b1066cc5066aa059fa21a5b430e3d5bfe3976d99c87b4b547ff4a947ed5')
prepare() {
+ # force python 'binary' as python2
+ [[ -d "$srcdir/path" ]] && rm -rf "$srcdir/path"
+ mkdir "$srcdir/path"
+ ln -s /usr/bin/python2 "$srcdir/path/python"
+
[[ -d kodi-build-x11 ]] && rm -rf kodi-build-x11
mkdir kodi-build-x11
[[ -d kodi-build-wayland ]] && rm -rf kodi-build-wayland
@@ -169,6 +174,8 @@ prepare() {
}
build() {
+ export PATH="$srcdir/path:$PATH"
+
### Optionally uncomment and setup to your liking
# export CFLAGS+=" -march=native"
# export CXXFLAGS="${CFLAGS}"
@@ -221,7 +228,6 @@ build() {
make
make preinstall
-
msg2 "building kodi-gbm"
cd "$srcdir/kodi-build-gbm"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
@@ -360,6 +366,8 @@ package_kodi-devel-eventclients() {
'kodi-eventclients-kodi-send'
)
+ export PATH="$srcdir/path:$PATH"
+
cd kodi-build-x11
# install eventclients
for _cmp in ${_components[@]}; do
@@ -419,6 +427,8 @@ package_kodi-devel-dev() {
'kodi-visualization-dev'
)
+ export PATH="$srcdir/path:$PATH"
+
cd kodi-build-x11
# install eventclients
for _cmp in ${_components[@]}; do
@@ -429,5 +439,6 @@ package_kodi-devel-dev() {
# python2 is being used
cd "$pkgdir"
- grep -lR '#!.*python' * | while read file; do sed -s 's/\(#!.*python\)/\12/g' -i "$file"; done
+ grep -lR '#!.*python' * | \
+ while read file; do sed -s 's/\(#!.*python\)/\12/g' -i "$file"; done
}