summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2017-02-06 23:17:50 +0100
committerMichael Lass2017-02-06 23:17:50 +0100
commitdd8ebf00bf012b2e6afd7c99a690a9c98dabb325 (patch)
tree8ba69a3e688072cc4e1acf4c7e41b8f7f7d602f3 /PKGBUILD
parentbd10602f993b14c1c06a3ce0fd91dc8750c86c5d (diff)
downloadaur-dd8ebf00bf012b2e6afd7c99a690a9c98dabb325.tar.gz
Update for Krypton
Also add kodi-dev to makedepends for Krypton and newer.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 007416b455bf..10b1732969f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,15 @@
# #
# API changes between different Kodi versions make it necessary to specify #
# the version of Kodi you want to build this package for. You can choose #
-# between Isengard (15), Jarvis (16) and git master (99). Do so in the #
-# following line. #
+# between Isengard (15), Jarvis (16), Krypton (17) and git master (99). Do so #
+# in the following line. #
+# #
###############################################################################
-API=16
+API=17
pkgname=kodi-platform-git
-pkgver=r38.15edaf7
+pkgver=r53.c8188d8
pkgrel=1
pkgdesc='Kodi platform support library'
arch=('armv7h' 'i686' 'x86_64')
@@ -37,8 +38,10 @@ case "$API" in
16) depends+=('libplatform-legacy')
source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=15edaf78d" ;;
17) depends+=('p8-platform')
+ makedepends+=('kodi-dev')
source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=c8188d826" ;;
- 99) depends+=('p8-platform') ;;
+ 99) depends+=('p8-platform')
+ makedepends+=('kodi-dev') ;;
*) error "Unknown API version. Follow instructions in PKGBUILD." && false
esac