summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAzphreal2017-02-14 11:25:28 +1100
committerAzphreal2017-02-14 11:25:28 +1100
commit0418358ddd8ef25c870bf040cb84287bf0b20431 (patch)
treea8c9f27e06d71c2e21f5b974a364646a33bcfc9a /PKGBUILD
downloadaur-0418358ddd8ef25c870bf040cb84287bf0b20431.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e426cdf8a6c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Alex Smith <azphreal19@protonmail.com
+pkgname=koel
+pkgver=3.5.5
+pkgrel=1
+pkgdesc="A personal music streaming server that works."
+arch=('any')
+url="http://koel.phanan.net/"
+license=('MIT')
+depends=('php' 'python3')
+makedepends=('php-composer')
+optdepends=('php-mysql: to use the MySQL database backend'
+ 'php-pgsql: to use the PostGreSQL database backend'
+ 'php-sqlsrv: to use the Microsoft SQL database backend'
+ 'mariadb: to use the MySQL database backend'
+ 'postgresql: to use the PostGreSQL database backend')
+
+backup=('usr/share/webapps/koel/.env')
+install="${pkgname}.install"
+source=("https://github.com/phanan/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('efd30b73a2df1fa8f97ef29eaadfdc2b5ba0f08a8aaf0a91826751e03eaed3bf')
+
+build() {
+ cd "$pkgname-$pkgver"
+ COMPOSER_CACHE_DIR="${srcdir/composer}" composer install
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "${pkgdir}/usr/share/webapps/${pkgname}"
+ cp -r * "${pkgdir}/usr/share/webapps/${pkgname}"
+}