summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2019-12-19 10:45:49 -0800
committerAnatol Pomozov2019-12-19 10:45:57 -0800
commitdc1441fb8e6eb7790964244ed12002c52fbc3388 (patch)
tree015b9dbc886e59834d0386b40fc7093a2728ce8d /PKGBUILD
parent681434eff156c7e0b5a6c5c66582a6ada71f095d (diff)
downloadaur-dc1441fb8e6eb7790964244ed12002c52fbc3388.tar.gz
updpkg
switch to python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfc226b1f062..8cdd9785a469 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Chao Wang <chaowang@redhat.com>
pkgname=koji
-pkgver=1.16.0
+pkgver=1.19.1
pkgrel=1
pkgdesc='shared libraries and the command-line interface for building and tracking RPMS'
arch=('any')
license=('GPL2' 'LGPL2.1')
url="https://pagure.io/koji"
-depends=('python2-dateutil' 'python2-krbv' 'python2-pyopenssl' 'urlgrabber' 'rpm-org' 'yum')
-makedepends=('python2')
+depends=('python-dateutil' 'python-six' 'python-requests-kerberos' 'python-pyopenssl' 'urlgrabber' 'rpm-org' 'yum')
+makedepends=('python')
backup=('etc/httpd/conf.d/kojihub.conf'
'etc/httpd/conf.d/kojiweb.conf'
'etc/koji-gc/koji-gc.conf'
@@ -25,19 +25,17 @@ backup=('etc/httpd/conf.d/kojihub.conf'
'etc/kojivmd/kojivmd.conf'
'etc/kojiweb/web.conf')
source=("https://releases.pagure.org/koji/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('b857d5c45cb18be7d1cc33a9324e2b8e7febb45c4422360ddeb3342fcfa3a668')
+sha256sums=('29b283a3e5cd7a5010e5d14498aed437d42767262f79bd1b85f358607af00480')
prepare() {
cd "$pkgname-$pkgver"
- find . -name Makefile -exec sed -i 's|\(PYTHON=\)python|\1python2|' {} \;
+ # find . -name Makefile -exec sed -i 's|\(PYTHON=\)python|\1python2|' {} \;
find . -name Makefile -exec sed -i 's|sbin|bin|' {} \;
find . -name '*.service' -exec sed -i 's|sbin|bin|' {} \;
- find . -type f -exec sed -i 's|^\(#!/usr/bin/\)python|\1python2|' {} \;
+ # find . -type f -exec sed -i 's|^\(#!/usr/bin/\)python|\1python2|' {} \;
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et: