summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick McCarty2015-07-12 11:58:42 -0700
committerPatrick McCarty2015-07-12 12:00:45 -0700
commite9e66788668883ed756ac70c50694b72553d3b2b (patch)
treebb6941add8c89f7692979dd734d5597ba838581f /PKGBUILD
parent3c43613c71962a2838af1c51765ac8d4f1cd2b49 (diff)
downloadaur-e9e66788668883ed756ac70c50694b72553d3b2b.tar.gz
Updates for packaging standards
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e678c65f0cd1..070d338de11f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,12 @@ source=("https://fedorahosted.org/released/${pkgname}/${pkgname}-${pkgver}.tar.b
sha256sums=('ec933af8359408b11478477de83b042a5bdf1d23e85683528aebb53c9bc0e6bc'
'f1bc4f65f4f7be2615336ce0e5d2fd728f6af2b6cd12f4d40ee59d204fa5ca9c')
-build() {
- cd $pkgname-$pkgver
- patch -p1 < ../makefile_python_to_python2.patch || return $?
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/makefile_python_to_python2.patch"
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR=$pkgdir -C koji install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" -C koji install
}