summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick McCarty2015-07-12 12:21:33 -0700
committerPatrick McCarty2015-07-12 12:36:24 -0700
commitec2b01f3f6acb90d752fcb5000c7728828c7f5c0 (patch)
treef83d313715977308ad157a3b3437123473a2633a /PKGBUILD
parent09f2108c72a120b42bf430ec471563e9986679bd (diff)
downloadaur-ec2b01f3f6acb90d752fcb5000c7728828c7f5c0.tar.gz
Run sed to apply python2 fixes instead of patch
Makefiles in other subdirectories also specify "PYTHON=python", so just run 'sed' on them instead to avoid patching the patch :)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b0fae747dcb..3324b11677b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,12 @@ license=('GPL2' 'LGPL2.1')
url=('https://fedorahosted.org/koji/')
depends=('python2-krbv' 'python2-pyopenssl' 'urlgrabber' 'rpm-org')
makedepends=('python2')
-source=("https://fedorahosted.org/released/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
- "makefile_python_to_python2.patch")
-sha256sums=('ec933af8359408b11478477de83b042a5bdf1d23e85683528aebb53c9bc0e6bc'
- 'f1bc4f65f4f7be2615336ce0e5d2fd728f6af2b6cd12f4d40ee59d204fa5ca9c')
+source=("https://fedorahosted.org/released/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('ec933af8359408b11478477de83b042a5bdf1d23e85683528aebb53c9bc0e6bc')
prepare() {
cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/makefile_python_to_python2.patch"
+ find . -name Makefile -exec sed -i 's|\(PYTHON=\)python|\1python2|' {} \;
}
package() {