summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThor K. H2018-07-16 10:27:12 +0200
committerThor K. H2018-07-16 10:27:12 +0200
commitd2961db0b796a2b5d9be21b1a9d92395975c383f (patch)
treec791d16cee9f03d5b1c647c48a7ada63be453698 /PKGBUILD
parent32a37ec6cfb2d070f30c760d166b67e87f863515 (diff)
downloadaur-d2961db0b796a2b5d9be21b1a9d92395975c383f.tar.gz
Updated to version 1.2.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4292444aa46..ebc6ffe47c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Thor M. K. Høgås <thor alfakrøll roht dott no>
+# Maintainer : Thor M. K. Høgås <thor alfakrøll roht dott no>
pkgname=koku-xinput-wine
-pkgver=1.2.1
+pkgver=1.2.3
pkgrel=1
_srcname="${pkgname}-${pkgver}"
pkgdesc="Adds xinput support to Wine without modifying the source binaries of Wine."
arch=('i686' 'x86_64')
url="https://www.github.com/KoKuToru/koku-xinput-wine"
-license=('custom:BSD2')
+license=('BSD')
+provides=("${pkgname}")
conflicts=("${pkgname}-git")
makedepends=('cmake' 'wine')
@@ -15,20 +16,22 @@ depends_x86_64=('lib32-sdl2')
depends_i686=('sdl2')
source=("${pkgname}::${url}/archive/v${pkgver}.tar.gz")
-md5sums=('c38ec13596471bdc46b1bea12b60a525')
+sha256sums=('9e38ee4db53e43543845843d8f1689a43b0100e6b326fbe716209fad3ce356b6')
build() {
cd "${srcdir}/${_srcname}"
- cmake .
- make
+ cmake -DCMAKE_BUILD_TYPE=Release .
+ make
}
package() {
cd "${srcdir}/${_srcname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/BSD2"
+
if [ "$CARCH" == "x86_64" ]; then
install -Dm755 koku-xinput-wine.so koku-xinput-wine64.so -t "${pkgdir}/usr/lib32/"
else
+ warning "i686 is not supported, although it may work, in this package."
install -Dm755 koku-xinput-wine.so -t "${pkgdir}/usr/lib/"
fi
}