summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 02:47:48 +0200
committerGoran Nushkov2019-04-06 02:47:48 +0200
commit1727b5ffb41b17690a907148fa342cdd9ea0f62d (patch)
treee37cd3a1975e5f0c7414b7400c40418a29bd9354 /PKGBUILD
parent0ea43f7bbbe72603d89a7ae02330b2c6787351bc (diff)
downloadaur-1727b5ffb41b17690a907148fa342cdd9ea0f62d.tar.gz
Fixed openresty location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f210b15982a8..8352a33fa0ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="https://getkong.org"
license=('Apache')
groups=('')
-depends=('libyaml' 'luajit' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
+depends=('libyaml' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
@@ -29,14 +29,14 @@ package(){
# Fix openresty location
cd usr/local/bin/
- sed -i "s:usr/local:opt:" kong
- sed -i "s:usr/local:opt:" json2lua
- sed -i "s:usr/local:opt:" lapis
- sed -i "s:usr/local:opt:" lua2json
- sed -i "s:usr/local:opt:" luarocks
- sed -i "s:usr/local:opt:" luarocks-5.1
- sed -i "s:usr/local:opt:" luarocks-admin
- sed -i "s:usr/local:opt:" luarocks-admin-5.1
+ sed -i "s+usr/local+opt+g" kong
+ sed -i "s+usr/local+opt+g" json2lua
+ sed -i "s+usr/local+opt+g" lapis
+ sed -i "s+usr/local+opt+g" lua2json
+ sed -i "s+usr/local+opt+g" luarocks
+ sed -i "s+usr/local+opt+g" luarocks-5.1
+ sed -i "s+usr/local+opt+g" luarocks-admin
+ sed -i "s+usr/local+opt+g" luarocks-admin-5.1
cd "${pkgdir}"
mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin