summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 02:00:06 +0200
committerGoran Nushkov2019-04-06 02:00:06 +0200
commit44f9ead7f4325cf4b2578e1bbc2d022048aa565a (patch)
tree3510620e206560404f1f1d9c7061e070bca5b46b /PKGBUILD
parent1fdeee0af1ad695bdb67aa114e95be405356b86c (diff)
downloadaur-44f9ead7f4325cf4b2578e1bbc2d022048aa565a.tar.gz
Fixed openresty location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bfa03dbeae2..848a8a0e6b24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,9 +26,17 @@ package(){
install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "/opt/openresty/pod/nginx/license_copyright.pod" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
- mkdir usr/bin 2> /dev/null; mv opt/bin/* usr/bin; rm -rf opt/bin
- rsync -a opt/* usr; rm -rf opt
+ # Fix openresty location
+ cd usr/local/bin/
+ sed "s:usr/local:opt:" kong > kongs
+ rm kong
+ mv kongs kong
+ cd "${pkgdir}"
+
+ mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+
+ rsync -a usr/local/* usr; rm -rf usr/local
cd ..