summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoran Nushkov2019-04-06 02:18:20 +0200
committerGoran Nushkov2019-04-06 02:18:20 +0200
commita7f14518974babc6896b23a56d8d67beed8c0865 (patch)
treeec343c127fa32db3cbeadd8acc475c66f35b5923 /PKGBUILD
parentde42428d92f09e46f03ca5fbf6acdb0026e5395c (diff)
downloadaur-a7f14518974babc6896b23a56d8d67beed8c0865.tar.gz
Fixed openresty location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6766312d8a75..080eeaefe140 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="https://getkong.org"
license=('Apache')
groups=('')
-depends=('libyaml' 'luajit' 'openssl' 'pcre' 'zlib' 'openresty' 'rsync')
+depends=('libyaml' 'openresty' 'openssl' 'pcre' 'zlib' 'rsync')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("https://bintray.com/kong/kong-community-edition-deb/download_file?file_path=dists/kong-community-edition-1.1.0.stretch.all.deb")
@@ -30,6 +30,13 @@ package(){
# Fix openresty location
cd usr/local/bin/
sed -i "s:usr/local:opt:" kong
+ sed -i "s:usr/local:opt:" json2lua
+ sed -i "s:usr/local:opt:" lapis
+ sed -i "s:usr/local:opt:" lua2json
+ sed -i "s:usr/local:opt:" luarocks
+ sed -i "s:usr/local:opt:" luarocks-5.1
+ sed -i "s:usr/local:opt:" luarocks-admin
+ sed -i "s:usr/local:opt:" luarocks-admin-5.1
cd "${pkgdir}"
mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin