summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2021-01-21 10:02:53 +0100
committerYour Name2021-01-21 10:02:53 +0100
commit2982ccc120950d6292075b49c62187ca43a798f8 (patch)
tree5c3bfb3d8fc03c7bf278660f6d1a99a724ebc15c /PKGBUILD
parent398ca1c2ce33035a4a7cba7ade24f35d9b00a158 (diff)
downloadaur-2982ccc120950d6292075b49c62187ca43a798f8.tar.gz
next iteration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1eed9e977ad..f64306a39a41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,6 +27,14 @@ _tagPrefix="kopanocore-"
#_tagPrefix=""
#_tagSuffix=""
+_basePkgName="${pkgname//-git/}"
+
+if [[ "${pkgname}" == *-git ]];
+then
+ # Version can't be set before pkgver has run
+ provides+=("${pkgname//-git/}=${pkgver}")
+fi
+
_gitLogByDay() {
local NEXT=$(date +%F)
local SINCE="1970-01-01"
@@ -54,7 +62,7 @@ pkgver() {
if [[ "${pkgname}" == *-git ]];
then
_lastTag=$(git tag -l "${_tagPrefix}*" --sort=v:refname | tail -n 1)
- _revision="r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _revision="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
if [ ! -z "${_lastTag}" ];
then
echo "${_lastTag}" | sed "s|${_tagPrefix}\(.*\)${_tagSuffix}|\1.r${_revision}|"
@@ -162,8 +170,9 @@ optdepends=(
# 'libs3'
)
+# TODO _licenseDir is supposed to be the pkgname. For unification changed here.
_confDir="etc/kopano"
-_licenseDir="usr/share/licenses/${pkgname}"
+_licenseDir="usr/share/licenses/kopano"
_docDir="usr/share/doc/kopano"
install='install'