summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2021-01-19 23:27:49 +0100
committerYour Name2021-01-19 23:27:49 +0100
commit6b14db6785fa239f9ef949315042bee3a7dd1691 (patch)
treee8fa49176a1e88f24aa5fb6bc9c3a1c0f49b987c /PKGBUILD
downloadaur-6b14db6785fa239f9ef949315042bee3a7dd1691.tar.gz
next iteration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e5ffad164c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+pkgname='kopano-libvmime-git'
+provides=(
+ 'libvmime'
+ )
+pkgver=0.9.2k4
+pkgrel=1
+pkgdesc='A C++ class library for working with MIME messages'
+arch=(
+ 'armv7l'
+ 'aarch64'
+ 'i686'
+ 'x86_64'
+ )
+url='http://www.vmime.org/'
+license=(
+ 'GPL'
+ )
+conflicts=(
+ 'libvmime'
+ 'libvmime-git'
+ 'zarafa-libvmime'
+ )
+source=(
+ "git+https://github.com/Kopano-dev/vmime.git#tag=v${pkgver}"
+ )
+md5sums=(
+ 'SKIP'
+ )
+
+
+makedepends=(
+ 'cmake'
+ 'postfix'
+ 'doxygen'
+ 'xdot'
+
+ # PKGBUILD dependencies
+ 'git'
+ )
+depends=(
+ 'gsasl'
+ 'gnutls'
+ )
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+
+ cmake ../vmime \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib/ \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file