summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIlya Fedin2021-05-01 02:58:18 +0400
committerIlya Fedin2021-05-01 02:58:18 +0400
commit0fa3173f0bb5fbeac5235b20e1ddbf2a25eac0f0 (patch)
treeeb7fab2f6dbd82dcbfe839f6b77ebd85d52f478d /PKGBUILD
parentefd4b3a8a4b6d867bbacc7564a845b04186085cd (diff)
downloadaur-0fa3173f0bb5fbeac5235b20e1ddbf2a25eac0f0.tar.gz
Update to 1.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d9caedf6dd1..1a78bba6a0bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ilya Fedin <fedin-ilja2010@ya.ru>
# Contributor: Auteiy <dmitry@auteiy.me>
pkgname=kotatogram-desktop
-pkgver=1.4
+pkgver=1.4.1
pkgrel=1
pkgdesc='Kotatogram – experimental Telegram Desktop fork'
arch=('x86_64')
url="https://kotatogram.github.io"
license=('GPL3')
depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
- 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'kwayland' 'gtk3' 'glibmm')
+ 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'kwayland' 'gtk3' 'glibmm' 'webkit2gtk')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'libtg_owt')
conflicts=('kotatogram-desktop-bin' 'kotatogram-desktop-dynamic-bin')
source=("${pkgname}::git+https://github.com/kotatogram/${pkgname}.git#tag=k${pkgver}"
@@ -29,6 +29,7 @@ source=("${pkgname}::git+https://github.com/kotatogram/${pkgname}.git#tag=k${pkg
"${pkgname}-lib_qr::git+https://github.com/desktop-app/lib_qr.git"
"${pkgname}-lib_webrtc::git+https://github.com/desktop-app/lib_webrtc.git"
"${pkgname}-tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git"
+ "${pkgname}-lib_webview::git+https://github.com/kotatogram/lib_webview.git"
"0001-Add-an-option-to-hide-messages-from-blocked-users-in.patch")
sha512sums=('SKIP'
'SKIP'
@@ -48,6 +49,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'13357d081fb658c735bb2575360f5d48214e1cf5002719ba410405a2fe05c7c3d2379588c2ca3c2ca6a5e6ff64e01e6d1ff3aecdaee8f3dd0519a64f6ee94182')
prepare() {
@@ -68,8 +70,9 @@ prepare() {
git config submodule.cmake.url "${srcdir}/${pkgname}-cmake_helpers"
git config submodule.Telegram/ThirdParty/QR.url "${srcdir}/${pkgname}-QR-Code-generator"
git config submodule.Telegram/lib_qr.url "${srcdir}/${pkgname}-lib_qr"
- git config sumbodule.Telegram/lib_webrtc.url "${srcdir}/${pkgname}-lib_webrtc"
- git config sumbodule.Telegram/ThirdParty/tgcalls.url "${srcdir}/${pkgname}-tgcalls"
+ git config submodule.Telegram/lib_webrtc.url "${srcdir}/${pkgname}-lib_webrtc"
+ git config submodule.Telegram/ThirdParty/tgcalls.url "${srcdir}/${pkgname}-tgcalls"
+ git config submodule.Telegram/lib_webview.url "${srcdir}/${pkgname}-lib_webview"
git submodule update
pushd cmake