summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilippe Hürlimann2019-04-17 14:04:20 +0200
committerPhilippe Hürlimann2019-04-17 14:04:20 +0200
commit4b40a46f64570d71af2e5e90866ef502a3eaf3c4 (patch)
tree0d4ea3fb9a5862a897480dbbd887cd0b55e5bad3 /PKGBUILD
downloadaur-4b40a46f64570d71af2e5e90866ef502a3eaf3c4.tar.gz
initial commit 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8e3f0fdce15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Philippe Hürlimann <p@hurlimann.org>
+pkgname=kotlin-native
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A LLVM backend for the Kotlin compiler"
+arch=('x86_64')
+url="https://github.com/JetBrains/kotlin-native"
+license=('Apache')
+options=('staticlibs' 'libtool' '!strip')
+depends=('java-environment' 'ncurses5-compat-libs')
+source=(${pkgname}-${pkgver}::https://github.com/JetBrains/kotlin-native/archive/v${pkgver}.tar.gz)
+sha512sums=('165f0aab2b60063cfd331991e5b353a0f47a4bb724929b593216aa4e72eeac1050f77a61c7e3d160502c3ff0c37fd941632d45a3833d7983265bf30deab97b61')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ ./gradlew dependencies:update
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./gradlew dist
+}
+
+package() {
+ mkdir -p ${pkgdir}/opt
+ mkdir -p ${pkgdir}/usr/bin
+ cp -R ${pkgname}-${pkgver}/dist ${pkgdir}/opt/kotlin-native
+ chmod 755 ${pkgdir}/opt/kotlin-native
+ ln -s /opt/kotlin-native/bin/kotlinc-native ${pkgdir}/usr/bin/kotlinc-native
+ ln -s /opt/kotlin-native/bin/konanc ${pkgdir}/usr/bin/konanc
+ ln -s /opt/kotlin-native/bin/cinterop ${pkgdir}/usr/bin/cinterop
+ ln -s /opt/kotlin-native/bin/run_konan ${pkgdir}/usr/bin/run_konan
+}