summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Heidelberg2014-04-25 09:06:00 +0200
committerMarkus Heidelberg2015-06-26 23:37:48 +0200
commit87164a3484f9f6c7fb98419802886d22fe251b5f (patch)
treeb4acc47f74159a4b694569d2e8de3e55f0ab60a2 /PKGBUILD
parentfcfe6ee7a827d94439ddd0bdb68060ceb4c73087 (diff)
downloadaur-87164a3484f9f6c7fb98419802886d22fe251b5f.tar.gz
koules 1.4-5: OSS sound emulation via ALSA
- move path/CFLAGS adaptions from build() to prepare() - add a patch for OSS sound emulation via ALSA This adds a dependency on the alsa-oss package, I hope this is in everyone's interest. Sound works out of the box for me now. alsa-oss has been added to "depends". Strictly speaking it would be sufficient to add it to "optdepends" + "makedepends", in which the "makedepends" could be avoided by adding oss-redir.h to the patch. But since sound support is elementary in a game, I decided to use a normal dependency. Please tell if there are reasons to change this. ** Manually imported from AUR 3 **
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5b9bf6cb70f..0eeef4bf9052 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,29 @@
# Contributor: Gyo <nucleogeek_at_gmail_dot_com>
pkgname=koules
pkgver=1.4
-pkgrel=4
+pkgrel=5
pkgdesc="A fast arcade game based on fundamental law of bodies attraction"
arch=('i686' 'x86_64')
url="http://www.ucw.cz/~hubicka/koules/English/"
license=('GPL')
-depends=('dialog' 'libx11' 'libxext')
+depends=('dialog' 'libx11' 'libxext' 'alsa-oss')
makedepends=('imake' 'xextproto' 'xproto')
source=(http://www.ucw.cz/~hubicka/koules/packages/$pkgname$pkgver-src.tar.gz
$pkgname-$pkgver-gcc3.patch
+ $pkgname-$pkgver-alsa-oss.patch
koules.desktop)
md5sums=('0a5ac9e57c8b72e9fc200bc98273235c'
'ccc92d4ab7d61ca482d30192a5ee83ec'
+ 'cbb37f907f7e8726be364434b75b66a9'
'fb3cd393464214643c239ac4350f963a')
prepare() {
cd "$srcdir/$pkgname$pkgver"
+
patch -p1 < "$srcdir/$pkgname-$pkgver-gcc3.patch"
-}
-build() {
- cd "$srcdir/$pkgname$pkgver"
+ rm -f oss-redir.c
+ patch -p1 < "$srcdir/$pkgname-$pkgver-alsa-oss.patch"
# some source modifications
sed -i \
@@ -32,6 +34,10 @@ build() {
sed -i \
-e "s:/usr/local/bin:/usr/bin:" \
-e 's:exec.*tcl:exec xkoules -M "$@":' koules
+}
+
+build() {
+ cd "$srcdir/$pkgname$pkgver"
# generate makefiles, then build
xmkmf -a