summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-10-17 05:33:30 +0200
committerml2020-10-17 05:41:55 +0200
commit1571ebb33b57b26bee414a7925208cdb46376000 (patch)
treedf9c6b6a1930e7250f5dc248b0ad2d6f98f3e64a /PKGBUILD
parenta1106c007137ea9acb565abc5d8e42f5437a2c1f (diff)
downloadaur-1571ebb33b57b26bee414a7925208cdb46376000.tar.gz
updpkg: kpt 0.35.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8460400480d..3d9c12d7fc50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: ml <ml@visu.li>
+# Maintainer: ml <>
pkgname=kpt
-pkgver=0.33.0
+pkgver=0.35.0
pkgrel=1
pkgdesc='Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations'
arch=('x86_64')
@@ -11,7 +11,7 @@ makedepends=('go')
optdepends=('asciinema: ttl command')
install=kpt.install
source=("https://github.com/GoogleContainerTools/kpt/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('6f50acd4bcebc7ad0668a43ba6e10651749d40ffb30ae0d331a31b5188cac25e')
+sha256sums=('ed237088f0851d76378c5a7cc24a9d2162773902143aeb798e22c5fd4a293c54')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -25,17 +25,17 @@ build() {
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -ldflags=-linkmode=external -modcacherw -mod=readonly -trimpath'
- go build -o "$pkgname"
+ export GOFLAGS='-buildmode=pie -modcacherw -mod=readonly -trimpath'
+ go build -o "$pkgname" -ldflags=-linkmode=external
}
-check() {
- cd "${pkgname}-${pkgver}"
- # ./internal only. we don't want e2e tests
-
- # not running any tests because they require configured Git identities
- #go test -short -failfast ./internal/...
-}
+# tests require configures Git identities
+# @TODO find safe way to set Git identities without violating $HOME privacy
+#check() {
+# cd "${pkgname}-${pkgver}"
+# # ./internal only. we don't want e2e tests
+# go test -short ./internal/...
+#}
package() {
cd "${pkgname}-${pkgver}"