summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-04-03 02:24:45 +0200
committerml2020-04-03 02:24:45 +0200
commit2dcc448b8d6ae667eebba99b86fd85c9860471e7 (patch)
tree34b35503ab156e66313b674d73f386a1d73524cf /PKGBUILD
downloadaur-2dcc448b8d6ae667eebba99b86fd85c9860471e7.tar.gz
newpkg: kpt 0.17.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..541c436bb0a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ml <ml@visu.li>
+pkgname=kpt
+pkgver=0.17.0
+pkgrel=1
+pkgdesc='Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations'
+arch=('x86_64')
+url='https://googlecontainertools.github.io/kpt/'
+license=('Apache')
+depends=('git')
+makedepends=('go')
+install=kpt.install
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GoogleContainerTools/kpt/archive/v${pkgver}.tar.gz")
+sha256sums=('460f54e3d0cff3ae5edf9f1bf5268d219c44c7c01d0ddf9e1d6f33f0ab01ddb8')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
+ go build -o "$pkgname"
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ # tests rely on git identity being present. fails in clean chroot env
+ #go test ./...
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "$pkgname" -t "${pkgdir}/usr/bin"
+}