summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-08-13 23:44:27 +0200
committerml2020-08-13 23:44:27 +0200
commita1106c007137ea9acb565abc5d8e42f5437a2c1f (patch)
treef9b08d920af75d06c8b870ddc3656d20c70b2f91 /PKGBUILD
parent02aa37fa18a1825c0539e57d60506c72fee5e4e3 (diff)
downloadaur-a1106c007137ea9acb565abc5d8e42f5437a2c1f.tar.gz
updpkg: kpt 0.33.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e185e6893c78..c8460400480d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <ml@visu.li>
pkgname=kpt
-pkgver=0.32.0
+pkgver=0.33.0
pkgrel=1
pkgdesc='Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations'
arch=('x86_64')
@@ -8,9 +8,10 @@ url='https://googlecontainertools.github.io/kpt/'
license=('Apache')
depends=('git')
makedepends=('go')
+optdepends=('asciinema: ttl command')
install=kpt.install
source=("https://github.com/GoogleContainerTools/kpt/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('4c17a63531acd5c6327dca55f5662d996a6bbcb18a7db989afae1cfe7ef71e45')
+sha256sums=('6f50acd4bcebc7ad0668a43ba6e10651749d40ffb30ae0d331a31b5188cac25e')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -24,14 +25,15 @@ build() {
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
+ export GOFLAGS='-buildmode=pie -ldflags=-linkmode=external -modcacherw -mod=readonly -trimpath'
go build -o "$pkgname"
}
check() {
cd "${pkgname}-${pkgver}"
# ./internal only. we don't want e2e tests
- # still git identity requires...
+
+ # not running any tests because they require configured Git identities
#go test -short -failfast ./internal/...
}