summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Lisin2020-06-01 15:21:42 +0200
committerMatthias Lisin2020-06-01 15:21:42 +0200
commitc3069317c2e98ffe12aa9479f148e46522998739 (patch)
treee7a1bc0c6f9f76531023035ce21db30a8a6be4d0 /PKGBUILD
parent2dcc448b8d6ae667eebba99b86fd85c9860471e7 (diff)
downloadaur-c3069317c2e98ffe12aa9479f148e46522998739.tar.gz
upgpkg: kpt 0.27.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 541c436bb0a7..2d8b87db6324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <ml@visu.li>
pkgname=kpt
-pkgver=0.17.0
+pkgver=0.27.0
pkgrel=1
pkgdesc='Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations'
arch=('x86_64')
@@ -10,19 +10,29 @@ depends=('git')
makedepends=('go')
install=kpt.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GoogleContainerTools/kpt/archive/v${pkgver}.tar.gz")
-sha256sums=('460f54e3d0cff3ae5edf9f1bf5268d219c44c7c01d0ddf9e1d6f33f0ab01ddb8')
+sha256sums=('19db15baceb358c6655b773463219a9669584506ef0b73bdfe16773a6a36525f')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ go mod download
+}
build() {
cd "${pkgname}-${pkgver}"
+ export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
- export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
go build -o "$pkgname"
}
check() {
cd "${pkgname}-${pkgver}"
- # tests rely on git identity being present. fails in clean chroot env
- #go test ./...
+ # ./internal only. we don't want e2e tests
+ # still git identity requires...
+ #go test -short -failfast ./internal/...
}
package() {