summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzlfn2022-06-18 01:19:19 +0900
committerzlfn2022-06-18 01:19:19 +0900
commitf9a817013d0fade8cf869f9b990243f9706c9514 (patch)
tree283e3546896077a7357947b5cb9e8024c8050f90 /PKGBUILD
parenta881003fea741419ffd3f964a853cdcdab36de9b (diff)
downloadaur-f9a817013d0fade8cf869f9b990243f9706c9514.tar.gz
ok
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 24 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32de62dd6502..6a6a621d9592 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: zlfn <dev@zlfn.space>
+# Maintainer: zlfn <elusive1102@naver.com>
pkgname=krita-plus-bin
-pkgver=v5.1.0.prealpha.r2166.g846124a477
+pkgver=v5.1.0.prealpha.r2174.g82766ef025
pkgrel=1
pkgdesc='The pre-built package of Krita Plus. If you do not trust me, intall krita-plus-git instead.'
arch=(x86_64)
@@ -17,6 +17,26 @@ optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations'
'krita-plugin-gmic: GMic plugin')
provides=(krita)
conflicts=(krita)
-source=(https://github.com/zlfn/krita-aur/releases/download/v5.1.0.prealpha.r2166.g846124a477/krita-plus-bin-v5.1.0.prealpha.r2166.g846124a477-1-x86_64.pkg.tar.zst)
-noextract=(krita-plus-bin-v5.1.0.prealpha.r2166.g846124a477-1-x86_64.pkg.tar.zst)
+source=('krita::git+https://github.com/KDE/krita.git#branch=krita/5.1')
sha512sums=('SKIP')
+
+pkgver() {
+ cd krita
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd ..
+ cd ..
+ echo $pkgver > pkgver
+ echo $pkgrel > pkgrel
+
+}
+
+build() {
+ cmake -B build -S krita \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_KRITA_QT_DESIGNER_PLUGINS=ON
+ cmake --build build -j 4
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}