summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier C. Llano2024-01-28 21:05:01 -0500
committerXavier C. Llano2024-01-28 21:05:01 -0500
commit5a1f0319bd22ca1622ce15f73fa7129ac412ad39 (patch)
tree7ad2f50152d698c39632b568ed8e994ee1eda510 /PKGBUILD
parentb4b065ce46c9c3fd3fa77f193c54633bf43299a6 (diff)
downloadaur-5a1f0319bd22ca1622ce15f73fa7129ac412ad39.tar.gz
update the build process
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bab35e5bd133..7ec565580a74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=krop
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="A tool to crop PDF files, with an eye towards eReaders."
arch=('any')
url="http://arminstraub.com/computer/krop"
@@ -12,13 +12,15 @@ makedepends=('sip')
source=("$pkgname-$pkgver.tar.gz::https://github.com/arminstraub/krop/archive/v${pkgver}.tar.gz")
sha256sums=('97022416ec4f2ff70e0ab38d3f3aaff83a68dca99f3e273c29e9f3dd72bf88d9')
+build() {
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
+}
+
package() {
cd $pkgname-$pkgver
- python setup.py install --root $pkgdir
- # Desktop icon
- install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
-
- # fix executable
- sed -i "s|krop==0.6.0|krop|g" $pkgdir/usr/bin/krop
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/krop/LICENSE"
}
+