summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2015-11-05 10:09:47 +0100
committerAntonio Rojas2015-11-05 10:09:47 +0100
commit8d8a3f3949afbf34229478aed0cdc488dcf14624 (patch)
treee61f5f149a9be063cd25c06c595a3b59cfc941c3 /PKGBUILD
downloadaur-8d8a3f3949afbf34229478aed0cdc488dcf14624.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fa6ca8eb38b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=kscreenlocker-git
+pkgver=r328.c4054d7
+pkgrel=1
+pkgdesc='Library and components for secure lock screen architecture'
+arch=(i686 x86_64)
+url='https://projects.kde.org/kscreenlocker'
+license=(LGPL)
+depends=(kdelibs4support plasma-framework kidletime kwayland)
+makedepends=(extra-cmake-modules git python)
+source=('git://anongit.kde.org/kscreenlocker.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd kscreenlocker
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kscreenlocker \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DSYSCONF_INSTALL_DIR=/etc \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}