summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-03-21 20:04:30 +0100
committerSefa Eyeoglu2020-03-21 20:04:30 +0100
commit65df560227d8af5aeff3201ef221304305f798ba (patch)
tree27ac252261f8e97063771b15eac6aca6522b5b49 /PKGBUILD
downloadaur-65df560227d8af5aeff3201ef221304305f798ba.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53602dfb2a3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=ktelephone
+pkgname=${_pkgname}-git
+pkgver=r80.f82037b
+pkgrel=1
+pkgdesc="Qt softphone - Highly inspired by Telephone"
+arch=(x86_64)
+url="https://github.com/StefanYohansson/ktelephone"
+license=("GPL3")
+depends=("pjproject" "qt5-multimedia")
+makedepends=("git" "cmake")
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${_pkgname}::git+https://github.com/StefanYohansson/ktelephone")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p "build"
+}
+
+build() {
+ cd "build"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ "../$_pkgname"
+
+ make
+}
+
+package() {
+ cd "build"
+
+ make DESTDIR="$pkgdir/" install
+}