summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:46:09 +0000
committerJoão Figueiredo2023-02-13 00:46:09 +0000
commit220f3f7ebf9b165ea9fa5f67169c239b6250befa (patch)
tree09df2a2a02a14e168ae3166ebe6b10be712c9855 /PKGBUILD
parentc63e6b4d3bdb56b0188799959bee6b6224e4ba47 (diff)
downloadaur-220f3f7ebf9b165ea9fa5f67169c239b6250befa.tar.gz
Migrate to Qt6 (this time for real!)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bedefd1e9019..98ae0edaca87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
pkgname=ktexteditor-git
-pkgver=5.240.0_r3750.ge5b165fd
+pkgver=5.240.0_r3753.g46b6c3c6
pkgrel=1
pkgdesc='Advanced embeddable text editor'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
depends=(kparts-git syntax-highlighting-git libgit2 editorconfig-core-c)
-makedepends=(git extra-cmake-modules-git doxygen qt5-tools)
+makedepends=(git extra-cmake-modules-git doxygen qt6-tools)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-groups=(kf5-git)
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}