summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Jaara2019-02-08 12:57:52 +0200
committerJesse Jaara2019-02-08 12:57:52 +0200
commitb43b7aecc992eb4797a0004b60b30471e3c4ebe0 (patch)
tree6a50e652ad42a714ae05c35d087231f3258c1fe7 /PKGBUILD
parentb4480c08f09d079d66e785dfa35a91935306b89c (diff)
downloadaur-b43b7aecc992eb4797a0004b60b30471e3c4ebe0.tar.gz
Update to v 0.30.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0b876a955d4..421311e4b6b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: p2k <uni-ulm.de: Patrick.Schneider>
pkgname=ktlint
-pkgver=0.24.0
+pkgver=0.30.0
pkgrel=1
pkgdesc="An anti-bikeshedding Kotlin linter with built-in formatter"
arch=('any')
@@ -10,17 +10,17 @@ url="https://ktlint.github.io/"
license=('CUSTOM: MIT')
depends=('java-runtime')
validpgpkeys=(160A7A9CF46221A56B06AD64461A804F2609FD89)
-source=(https://github.com/shyiko/ktlint/releases/download/${pkgver}/ktlint
+source=(ktlint-${pkgver}::https://github.com/shyiko/ktlint/releases/download/${pkgver}/ktlint
https://raw.githubusercontent.com/shyiko/ktlint/${pkgver}/LICENSE
- https://github.com/shyiko/ktlint/releases/download/${pkgver}/ktlint.asc)
-sha256sums=('701ed9478a9d217f3b82efda0fa9db3e4028b3951066b6ad99e0db6c6d7c9370'
+ ktlint-${pkgver}.asc::https://github.com/shyiko/ktlint/releases/download/${pkgver}/ktlint.asc)
+sha256sums=('163e99cd6cef9bb05d1066bdbff061b1a39023cc35c898b21e321e86091e7050'
'94fcaa8988fceec75f68ae8b31bb51676e4afc2534072b6e634a986700804f94'
'SKIP')
package() {
cd "${srcdir}"
- install -D -m755 ktlint "${pkgdir}/usr/bin/ktlint"
+ install -D -m755 ktlint-${pkgver} "${pkgdir}/usr/bin/ktlint"
install -D -m644 LICENSE "${pkgdir}/usr/share/license/ktlint/LICENSE"
}