summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2019-03-04 21:54:47 -0500
committerDavid Birks2019-03-04 21:54:47 -0500
commit596a7a1ee45eb819bb6d7c0e5d89b11650298496 (patch)
treebeed84e1619432a2582c5c5b6b86b5e67d8d7071 /PKGBUILD
parent39d21a454d764b8208d23dc49a870f39898d5881 (diff)
downloadaur-596a7a1ee45eb819bb6d7c0e5d89b11650298496.tar.gz
Add bash and zsh completion
Thanks to the kubectl PKGBUILD Also updated description
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01af50e4fb37..de2a2842f14e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,22 @@
# Contributor: colemickens <cole.mickens@gmail.com>
pkgname=kubectl-beta-bin
-pkgdesc="Kubernetes.io client binary (beta)"
+pkgdesc="Command-line tool for deploying and managing applications on Kubernetes (beta)"
pkgver=1.14.0_beta.1
pkgrel=1
arch=('x86_64')
-url="http://kubernetes.io"
+url="https://github.com/kubernetes/kubernetes"
license=('apache')
-provides=('kubectl-bin')
+provides=('kubectl' 'kubectl-bin')
conflicts=('kubectl' 'kubectl-bin' 'kubernetes>=1.4.6')
source=("kubectl-${pkgver//_/-}::https://storage.googleapis.com/kubernetes-release/release/v${pkgver//_/-}/bin/linux/amd64/kubectl")
sha256sums=('31a027f335bf6c5042eadaea9b4623b28e6255560ed502eeb697d3313124f5bd')
package() {
install -Dm 755 "$srcdir/kubectl-${pkgver//_/-}" "$pkgdir/usr/bin/kubectl"
+ # Populate bash and zsh completions
+ install -d 755 "$pkgdir/usr/share/bash-completion/completions"
+ install -d 755 "$pkgdir/usr/share/zsh/site-functions"
+ "$pkgdir/usr/bin/kubectl" completion bash > "$pkgdir/usr/share/bash-completion/completions/kubectl"
+ "$pkgdir/usr/bin/kubectl" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_kubectl"
}