summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2019-04-15 09:32:50 -0400
committerDavid Birks2019-04-15 09:32:50 -0400
commita9e679baacd6b1c364d146056ba400b6e23ce1da (patch)
treeb23c1e23cecec95b2e92bac1ae48f67ad039423b /PKGBUILD
parentdb50f697b6436c56905a32f389823766397de692 (diff)
downloadaur-a9e679baacd6b1c364d146056ba400b6e23ce1da.tar.gz
Fix completion installation
Was previously also creating a directory called 755
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccd08f837fc6..4f65ae3b5bf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ sha512sums=('552763bb1da248bb4c32a9146d3be504ed8e49e8c13482538e8fb16aaf7a2f46dfc
package() {
install -Dm 755 "$srcdir/kubectl-${pkgver//_/-}" "$pkgdir/usr/bin/kubectl"
# Populate bash and zsh completions
- install -d 755 "$pkgdir/usr/share/bash-completion/completions"
- install -d 755 "$pkgdir/usr/share/zsh/site-functions"
+ install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
+ install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
"$pkgdir/usr/bin/kubectl" completion bash > "$pkgdir/usr/share/bash-completion/completions/kubectl"
"$pkgdir/usr/bin/kubectl" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_kubectl"
}