summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2021-10-29 15:28:56 +0200
committerml2021-10-29 15:28:56 +0200
commit2e81a6abac3cdf7739b4190725432fa8fc25501d (patch)
tree4aefdb1d12545081b6ed799bce0b73fece92bd69 /PKGBUILD
parentc1d7c5f2c1ae7f07c8412f27fee143ec1150a010 (diff)
downloadaur-2e81a6abac3cdf7739b4190725432fa8fc25501d.tar.gz
updpkg: kubectl-neat 2.0.3-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf8c5a9a271e..bad78c3464de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: ml <ml@visu.li>
+# Maintainer: ml <>
pkgname=kubectl-neat
-pkgver=2.0.2
+pkgver=2.0.3
pkgrel=1
pkgdesc='Clean up Kuberntes yaml and json output to make it readable'
arch=('x86_64' 'aarch64')
@@ -9,27 +9,22 @@ license=('Apache')
depends=('kubectl')
makedepends=('go')
groups=('kubectl-plugins')
-source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('18adb7b34d3ffbc3967ab976cdfa3d553be44bec3c46f056bc8e34d585e2d52f')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('d4788cac64102db35c69e21d99a67a08a83848f955cb9bf14fa9a56c49935b4f')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly -ldflags=-linkmode=external'
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw -ldflags=-linkmode=external'
go build -o "$pkgname"
}
-check() {
- cd "${pkgname}-${pkgver}"
- go test -short ./...
-}
-
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 ${pkgname} -t "${pkgdir}/usr/bin"
- install -Dm644 demo.png Readme.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 demo.png Readme.md -t "$pkgdir/usr/share/doc/$pkgname"
}