summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatoly Rugalev2022-04-14 00:07:38 +0200
committerAnatoly Rugalev2022-04-14 00:07:38 +0200
commit85632a1d533e500468a5ee23d4b7e5bc6fdfb209 (patch)
tree9372f0e5f6a7021869a8b5ccc54cee486ddbb198 /PKGBUILD
parent971853ada61084881a3c2b92a4d2232c72b2167e (diff)
downloadaur-85632a1d533e500468a5ee23d4b7e5bc6fdfb209.tar.gz
Support aarch64, i486 and i686
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f5d97f69932..709d51dbff74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,25 @@
pkgname=kubernetes-helmfile-bin
pkgver=0.144.0
-pkgrel=1
+pkgrel=2
pkgdesc="Deploy Kubernetes Helm Charts"
url="https://github.com/roboll/helmfile"
license=('MIT')
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'i486' 'i686')
depends=('helm')
-source=("helmfile_linux_amd64_$pkgver::https://github.com/roboll/helmfile/releases/download/v$pkgver/helmfile_linux_amd64")
-sha256sums=('dcf865a715028d3a61e2fec09f2a0beaeb7ff10cde32e096bf94aeb9a6eb4f02')
+source_x86_64=("helmfile_linux_${pkgver}_x86_64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_amd64")
+source_i486=("helmfile_linux_${pkgver}_i486::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_i686=("helmfile_linux_${pkgver}_i686::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_aarch64=("helmfile_linux_${pkgver}_aarch64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_arm64")
+
package() {
- cd "$srcdir"
- install -d "$pkgdir/usr/bin"
- install -m755 helmfile_linux_amd64_$pkgver "$pkgdir/usr/bin/helmfile"
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/bin"
+ install -m755 helmfile_linux_${pkgver}_${CARCH} "${pkgdir}/usr/bin/helmfile"
}
+sha256sums_x86_64=('dcf865a715028d3a61e2fec09f2a0beaeb7ff10cde32e096bf94aeb9a6eb4f02')
+sha256sums_aarch64=('8461bbb13ba23f4333dc99d96bf7a24c283cd7683e746acf639d80bbd828926a')
+sha256sums_i486=('7c75e13b062ebbe1ea09120f5ca03556895482ea92c545c13148407005eb1a66')
+sha256sums_i686=('7c75e13b062ebbe1ea09120f5ca03556895482ea92c545c13148407005eb1a66')