summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWael M. Nasreddine2017-06-12 10:33:07 -0700
committerWael M. Nasreddine2017-06-12 10:33:07 -0700
commit19060762e39666b898cdb373c697525cf39441b4 (patch)
treee4000b37497f3d72f5c234bf50ada7f4b950d8a8 /PKGBUILD
downloadaur-19060762e39666b898cdb373c697525cf39441b4.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a4915aa3b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Wael Nasreddine <wael.nasreddine@gmail.com>
+
+pkgname=kubetail
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Bash script that enables you to aggregate (tail/follow) logs from multiple pods into one stream"
+arch=('any')
+url="https://github.com/johanhaleby/kubetail"
+license=('Apache')
+depends=('kubectl-bin')
+source=(https://github.com/johanhaleby/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('460d9980033b22631fde19002537162f')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 kubetail "$pkgdir/usr/bin/kubetail"
+}
+