summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2017-02-06 15:09:34 +0100
committerSanskritFritz2017-02-06 15:09:34 +0100
commita80414a895173d03fce73b7a7fa940a8990eabe1 (patch)
treee9a06fa3264442c68dd501be7e5c328ef9bd907a /PKGBUILD
parent1712dfbac33e00c801ac094e5052a876c02d5198 (diff)
downloadaur-a80414a895173d03fce73b7a7fa940a8990eabe1.tar.gz
"A new decade of Kupfer dawns"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36bc6db4d382..4c5018f45b69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: D. Can Celasun <dcelasun[at]gmail[dot]com>
# Maintainer: SanskritFritz (gmail)
_name=kupfer
pkgname=$_name-git
-pkgver=2015.09.04
+pkgver=v301.r2.g2bae3642
pkgrel=1
pkgdesc="An interface for quick and convenient access to applications and their documents."
arch=(any)
-url="http://engla.github.io/kupfer/"
+url="https://kupferlauncher.github.io/"
license=('GPL')
-depends=('python2-xdg' 'pygtk' 'python2-dbus' 'python2-gconf' 'python2-keybinder2'
- 'hicolor-icon-theme' 'desktop-file-utils')
+depends=('libkeybinder3' 'python-dbus' 'python' 'python-cairo' 'libwnck3')
+makedepends=('python2' 'intltool')
optdepends=('gnome-python-desktop: enables all plugins and gnome integration'
- 'python2-gnomekeyring: gnome keyring integration'
- 'python2-wnck: tracks running applications'
- 'python2-setproctitle: set process name'
- 'python2-gdata: google services'
'xautomation: enables the Send Keys plugin')
-makedepends=('git' 'gnome-doc-utils' 'docutils' 'intltool')
+makedepends=('python2' 'intltool' 'git')
provides=("$_name")
conflicts=("$_name")
-install="$pkgname.install"
-source=("git://git.gnome.org/$_name")
+source=("git+https://github.com/kupferlauncher/kupfer.git")
md5sums=('SKIP')
pkgver() {
cd "$_name"
- git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/$_name"
- # python2 fixes
- export PYTHON=/usr/bin/python2
+
+ # fix man page generation
+ sed -i 's_rst2man_&2_Ig' wscript
+
+ export PYTHON=/usr/bin/python
python2 waf configure --prefix=/usr --no-update-mime --no-update-icon-cache
python2 waf