summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVianney Bouchaud2023-01-03 11:20:42 +0100
committerVianney Bouchaud2023-01-03 11:20:42 +0100
commite65216abd196e5c5b3c6ff96566df7e862a76a6b (patch)
tree1c4592f6db2cd23fb645fdb465c5d0bf8b12163f /PKGBUILD
downloadaur-e65216abd196e5c5b3c6ff96566df7e862a76a6b.tar.gz
Initial upload: kured-sentinel 1.0.0-1
adding kured-sentinel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..216528a5d65f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Vianney Bouchaud <aur dot vianney at bouchaud dot org>
+
+pkgname=kured-sentinel
+pkgdesc="Pacman hook to create the sentinel file for kured."
+pkgver=1.0.0
+pkgrel=1
+arch=("any")
+url="https://github.com/vbouchaud/aur/tree/main/kured-sentinel"
+license=("MIT")
+depends=("longoverdue")
+
+sha256sums=(
+ c050b7b8b6bb244b16ad84c3d162b91ddbf9ebaeda423df7418e4ad646fe99b3
+ 9124af974ca641ff1421bc077ae6e4f7dae0704bf0ba7a7d6630d75afdbe1a06
+)
+
+source=(
+ kured-sentinel
+ kured-sentinel.hook
+)
+
+package() {
+ install -D -m0644 "${srcdir}/kured-sentinel.hook" "${pkgdir}/usr/share/libalpm/hooks/kured-sentinel.hook"
+ install -D -m0755 "${srcdir}/kured-sentinel" "${pkgdir}/usr/bin/kured-sentinel"
+}