summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-09 16:23:14 +0000
committerDaniel Bermond2019-06-09 16:24:28 +0000
commit03444d1b8ceb6ab4804cb128e58275ac97e6ef04 (patch)
tree0f1f5ea05401d9b4d2b9abb68e9f8bed5314ea44 /PKGBUILD
parentbbeea7b3159bc9311fd09f066d7fbbdd23071763 (diff)
downloadaur-03444d1b8ceb6ab4804cb128e58275ac97e6ef04.tar.gz
Remove i686. Remove so-provide. Do not rename clone dir. Add tests.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 27 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0581ccecbd93..756ab74966cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,64 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# Contributor: Devaux Fabien <fdev31@gmail.com>
pkgname=kvazaar-git
-pkgver=1.2.0.r71.g6be81959
+pkgver=1.2.0.r313.g933ff6ed
pkgrel=1
pkgdesc='An open-source HEVC encoder (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://ultravideo.cs.tut.fi/#encoder'
license=('LGPL')
depends=('glibc' 'gcc-libs' 'crypto++')
makedepends=('git' 'yasm')
-provides=('kvazaar' 'libkvazaar.so')
+checkdepends=('ffmpeg' 'hm')
+provides=('kvazaar')
conflicts=('kvazaar')
-source=("$pkgname"::'git+https://github.com/ultravideo/kvazaar.git'
- 'kvazaar-submodule-greatest'::'git+https://github.com/ultravideo/greatest.git')
+source=('git+https://github.com/ultravideo/kvazaar.git'
+ 'git+https://github.com/ultravideo/greatest.git'
+ 'kvazaar-git-disable-test-external-symbols.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '3a4dd1b38d58751381b24c81a86c21df7cfdc85ba5c6a13d879f112e463189b9')
prepare() {
- cd "$pkgname"
+ cd kvazaar
git submodule init
- git config --local submodule.greatest.url "${srcdir}/kvazaar-submodule-greatest"
+ git config --local submodule.greatest.url "${srcdir}/greatest"
git submodule update
+
+ # disable a test that is failing: test_external_symbols.sh
+ # https://github.com/ultravideo/kvazaar/issues/215
+ patch -Np1 -i "${srcdir}/kvazaar-git-disable-test-external-symbols.patch"
+
+ ./autogen.sh
}
pkgver() {
- cd "$pkgname"
+ cd kvazaar
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgname"
-
- ./autogen.sh
+ cd kvazaar
./configure \
--prefix='/usr' \
- --enable-largefile \
- --enable-static='no' \
- --enable-shared='yes' \
- --enable-fast-install='yes' \
--with-cryptopp
make
}
+check() {
+ cd kvazaar
+
+ make check
+}
+
package() {
- cd "$pkgname"
+ cd kvazaar
make DESTDIR="$pkgdir" install
}