summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Wozniak2017-02-26 13:52:26 +0100
committerPatrick Wozniak2017-02-26 13:53:39 +0100
commit3e013ab1f4cd3206c648ab584e6c990d3a417fd8 (patch)
treebeb03dc758455ad18555ee4c66df7b1793205960 /PKGBUILD
downloadaur-kwakd-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a85a612296b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Tom Vincent <http://tlvince.com/contact>
+# Contributor: Jente Hidskes <hjdskes@gmail.com>
+# Maintainer: Patrick Wozniak <hello@patwoz.de>
+
+pkgname=kwakd-git
+_gitname=kwakd
+pkgver=r12.acdf0e1
+pkgrel=1
+pkgdesc="A web server serving blank html pages"
+url="https://github.com/fetchinson/$_gitname"
+arch=('any' )
+license=("GPL")
+depends=('bash')
+makedepends=('git')
+conflicts=('kwakd')
+source=(
+ "git://github.com/fetchinson/${_gitname}.git"
+ "${_gitname}.service"
+)
+install="${_gitname}.install"
+sha256sums=(
+ 'SKIP'
+ '5ae20e1ef81436ba5452447c32c46db4d343f08f5abe0aa41076425a9cee4715'
+)
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR=$pkgdir install
+ install -Dm644 "$srcdir/$_gitname.service" "$pkgdir/usr/lib/systemd/system/$_gitname.service"
+}
+