summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:45:47 +0000
committerJoão Figueiredo2023-02-13 00:45:47 +0000
commit457ee8d512585a40983a2b700b82fc60d4cdca1b (patch)
treed0f2e0b25dc88f0c75caabdc7d50293fe0c92e7e /PKGBUILD
parenta2c2382d1cc66832a80d8a90c40cd78b638344e1 (diff)
downloadaur-457ee8d512585a40983a2b700b82fc60d4cdca1b.tar.gz
Migrate to Qt6 (this time for real!)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63c1a4c14b6f..f9e924ecf8a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries'
arch=($CARCH)
url='https://www.kde.org'
license=(LGPL)
-depends=(qt5-wayland)
-makedepends=(git extra-cmake-modules-git doxygen qt5-tools wayland-protocols plasma-wayland-protocols-git)
+depends=(qt6-wayland)
+makedepends=(git extra-cmake-modules-git doxygen qt6-tools wayland-protocols plasma-wayland-protocols-git)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-groups=(kf5-git)
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}