diff options
author | João Figueiredo | 2023-02-13 00:45:47 +0000 |
---|---|---|
committer | João Figueiredo | 2023-02-13 00:45:47 +0000 |
commit | 457ee8d512585a40983a2b700b82fc60d4cdca1b (patch) | |
tree | d0f2e0b25dc88f0c75caabdc7d50293fe0c92e7e /PKGBUILD | |
parent | a2c2382d1cc66832a80d8a90c40cd78b638344e1 (diff) | |
download | aur-457ee8d512585a40983a2b700b82fc60d4cdca1b.tar.gz |
Migrate to Qt6 (this time for real!)
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -9,17 +9,17 @@ pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries' arch=($CARCH) url='https://www.kde.org' license=(LGPL) -depends=(qt5-wayland) -makedepends=(git extra-cmake-modules-git doxygen qt5-tools wayland-protocols plasma-wayland-protocols-git) +depends=(qt6-wayland) +makedepends=(git extra-cmake-modules-git doxygen qt6-tools wayland-protocols plasma-wayland-protocols-git) conflicts=(${pkgname%-git}) provides=(${pkgname%-git}) -groups=(kf5-git) +groups=(kf6-git) source=("git+https://github.com/KDE/${pkgname%-git}.git") sha256sums=('SKIP') pkgver() { cd ${pkgname%-git} - _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)" + _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)" echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)" } |